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Introduction
The Updating an Existing DITA CMS Deployment (Update Guide) explains how to bring your
deployment up to date to a more current build release. The build number of the software increases
(for example, from 1.2.7 to 1.2.8) to introduce bug fixes, which may require small updates to the
DITA CMS components.
To update your deployment, you must update each component in your deployment with the newer
version of the software and then you may also need to make some changes to some components'
configuration files to support the changes made in the software.
If you are upgrading to a minor version (for example, from version 1.1 to 1.2) or to a major version
(for example, from version 1.2 to 2.0), you must follow the instructions in Upgrading the DITA
CMS to [version number] instead. An upgrade may require may require upgrades to the underlying
framework, configuration changes, or upgrades to the DITA CMS components which are provided
in that document.

What's new in each release
End of Support
The IXIASOFT Web Author and Web Collaborative Review modules are being merged into a
unique DITA CMS Web component to take your content creation and reviewing processes to
the next level. The DITA CMS Web component will include the authoring and reviewing features
available today as well as new features, such as a map view, topic and map creation, as well
as map editing.
As such, all support for Web Author and Web Collaborative Reviewer will stop by December
31st, 2017.
The following sections list the new features and enhancements have been added to each release.
For more information, open the document listed in the Documents affected column and navigate
to the topic called "New in this documentation release".
Build 4.3.61
Features

Documents affected

None.

None.
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Build 4.3.57
Features

Documents affected

A new script is now available to simplify making Output Generator Installation Guide
the Output Generator files executable on Linux
for deployments that use source control.
The Preview view has been updated to support None.
topics containing DITA 1.3 elements.
Build 4.3.47
Features

Documents affected

Two new attributes, default and authoring,
have been added to the languages.xml
configuration file to allow system administrators
to set a default authoring language and to
define which languages are used in the
Authoring cycle and which are used in the
Localization cycle.

DITA CMS Administrator's Guide

A new attribute, deprecated, has been added
to the conditionaltext.xml configuration file to
allow system administrators to deprecate a
conditional attribute value.

DITA CMS Administrator's Guide

Automatically add oXygen XML Editor's
document types extensions (framework
extensions) into the oXygen Editor's
Preferences when the DITA CMS Eclipse
Clients are launched.

DITA CMS Administrator's Guide

The import process has been improved so
non-DITA files referenced by an imported
object are imported as resources identified as
type "unknown", which allows them to be
searchable from the Search view.

DITA CMS Administrator's Guide

Introduction

Features

9

Documents affected

The import process has changed. When you
import an image to replace an image in a
multiple resolution image object, all the formats
are replaced by the imported image.

oXygen: DITA CMS User Guide

The Assignments dialog box has been
improved so that an HTTP or HTTPS-based
URL can be added to an assigned document
as an external link.

oXygen: DITA CMS User Guide

The Assignments dialog box has been
improved to allow filtering of the names
displayed in the Assignee pane by project even
if the document being assigned is not one of
the project's deliverables.

oXygen: DITA CMS User Guide

A new feature called Clone Ditaval has been
added to the Ditaval view. This feature allows
you to create a clone of an existing Ditaval file
to use as a basis for a new Ditaval.

oXygen: DITA CMS User Guide

The Create Ditaval and Edit Ditaval dialog
boxes have been enhanced to support subject
schemes.

oXygen: DITA CMS User Guide

XMetaL: DITA CMS User Guide

XMetaL: DITA CMS User Guide

XMetaL: DITA CMS User Guide

XMetaL: DITA CMS User Guide

XMetaL: DITA CMS User Guide

The Dynamic Release Management Module Dynamic Release Management Module User
User Guide now includes documentation about Guide
the DRM refactor feature.
To better support the DRM multi-level library
Dynamic Release Management Module User
feature, it is no longer possible to create or
Guide
import topics, images, and resources into more
than one product or library.
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Build 4.3.33
Features

Documents affected

None

None

1

Understanding the process for
updating a deployment

Understanding the process for updating a deployment

Topics:

•
•
•

Update the deployment
(overview)
Testing after modifications
Restarting DITA CMS
components after TEXTML
Server is restarted

Minor and build release versions may introduce new features
and bug fixes that require configuration changes or updates
to components.
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Update the deployment (overview)
When you update a deployment to a new build version, you need to perform a series of tasks to
update the configuration and the software for each component in the deployment.
For any change you need to make in your deployment, your main concern should be to avoid
disturbing your production environment as much as possible.This means that you need to identify
exactly what changes you need to make, how to make them, and what the consequences of
those changes are.
Since each deployment is different, you should attempt the changes on a separate environment
not used for production. This environment is often referred to as a test environment. The purpose
of making changes in a test environment first is to learn what is needed to adapt the general
instructions provided by IXIASOFT to the specific requirements in your deployment. The goal is
to produce a set of procedures documenting specifically what you need to do to your production
environment.
When you update the deployment to a newer build, you need to:
• Apply the configuration changes required by each build release to the Content Store.
• Update the software binaries of each component to the newer build release.
The specific configuration changes required by each build release are listed in Updating the
system configuration in the Content Store on page 17. If software releases have occurred
between your currently installed version and the version to which you want to update, you must
apply the configuration changes from each build release to the affected components in your
deployment.
The specifics of how to update the software for each component is explained in Updating the
software binaries on page 31. Since a build release is a cumulative set of fixes and software
changes of the previous releases, you only need to install the version to which you want to update
(and not each individual build in between).
Important: Before you upgrade, update, or make modifications to a component, make
sure that a current and valid backup copy of that component is saved in the backup storage
location.
The overall summary of the process is as follows:
1. Ensure that you have current backups of the components.
For more information about backups, see Maintaining a DITA CMS Deployment Toolsmith's
Guide.

Understanding the process for updating a deployment
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2. In your test environment, make all the configuration changes to the components as
required for each build release and document the specific steps you need to do in your
deployment as specified in Updating the system configuration in the Content Store on
page 17.
Important: You must apply ALL the configuration changes that occurred in each build
release between your installed build version and the one you wish to install. For
example, if you have build 4.2.31 installed and you want to update to 4.2.38, then you
must apply all the configuration changes listed for builds 4.2.33, 4.2.34, and 4.2.38.
3. In your test environment, update the software for each component as described in
Updating the software binaries on page 31.
4. Perform tests in the test environment to verify that the update was implemented
correctly, bug fixes mentioned in the release notes work as described, and any custom
solutions that you have implemented in your deployment continue to work as they did
previously.
5. If you have a validation environment, repeat the update according to the specific
procedures that you documented when you updated the test environment and repeat
your tests to confirm that they work as expected.
6. Once you are satisfied that the test (or validation) environment is working adequately,
update the software and configuration for each component in your production
environment according to the specific update instructions you documented while
updating the test environment.
7. Repeat the tests that you performed in the test environment in the production
environment to verify that everything is working as expected.

Testing after modifications
How you test a modification depends on the component and type of modification you made.
Always implement and test modifications on a test environment before attempting them on the
production environment. As you work on the modification, document your procedure so you can
follow it when you test the procedure in a validation environment and then implement the changes
on the production environment. Check logs for warnings and errors. Making untested changes
directly in the production environment is not recommended since it may cause serious unwanted
effects or render the environment unusable.
Any customized solution you have built on any of the components should be tested after each
modification, upgrade, or update. Changes made as a result of the modification, upgrade, or
update may inadvertently break the custom solution.
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For example, if an IXIASOFT file was changed while implementing a customized functionality
into the Output Generator, the IXIASOFT file may be overwritten when the next upgrade or update
is performed, which may cause the functionality to break.
Testing TEXTML Server
If you are performing an upgrade or update, follow the instructions in a test environment and note
the specific procedures needed for your deployment before proceeding with validating and
implementing the changes in the production environment.
If you made changes to TEXTML Server's configuration files, test the changes on a validation
environment to confirm that the changes were applied successfully and no regressions have
occurred (for example, are fixes that you implemented in the past are still working after the
upgrade or update?).
If the changes were implemented to fix a problem, follow the steps to reproduce the problem and
confirm that the problem no longer occurs.
Testing the Content Store
If you made changes to the workflow, move the object between states to confirm that the changes
were applied successfully, the behavior is as expected, and no regressions have occurred.
Remember: Before you rename or remove a status, you will first need to move all objects
out of the status being renamed or removed before you make the change.
If you made changes to a DTD, lock and release objects containing new and old content affected
by the DTD changes to confirm they are still valid.
If you made small configuration changes, verify if the changes were applied successfully and no
regressions have occurred.
Testing the DITA CMS Eclipse Client
Test fixes for resolved bugs or configuration changes by performing actions in the DITA CMS
Eclipse Client which confirm the fixes or changes work as expected.
Testing Output Generator
Test changes to the plugins, DTDs, renderers (such as XEP, FOP, Antenna House), or a conductor
file in the DITA Open Toolkit by generating an output that should be affected by the changes you
made and confirm that they were applied successfully and no regressions have occurred.

Understanding the process for updating a deployment
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To facilitate testing, it is recommended that you create a test map with topics containing all the
edge cases in your content for your exclusive use for testing the Output Generator. You can then
keep a copy of the output from the test map as your 'Approved Output'. When you make a change
to the Output Generator, you can compare the new output to your Approved Output to identify
any unwanted changes.
Testing Scheduler
Test your changes by instigating a situation to trigger the action so you can confirm that the
behavior is as expected. For example, you can perform a status change that causes DITA CMS
to execute a job trigger.
Testing Web Collaborative Reviewer (WCR)
Perform regression testing to ensure that all existing functionality still works after the changes
were implemented.
Testing Web Author
Perform regression testing to ensure that all existing functionality still works after the changes
were implemented.

Restarting DITA CMS components after TEXTML Server
is restarted
Components must be restarted in order depending on their dependencies on other components.
The following figure can be used to visualize the dependencies between the components. The
arrows indicate the direction communication is established between the components, but it can
also be used to understand the flow of dependency from the components at the top of the figure
to those below.The unidirectional arrow from one component to another points to which component
needs to be running before it is restarted. For example, the DITA CMS Eclipse Client points to
TEXTML Server; therefore, TEXTML Server must be restarted before the DITA CMS Eclipse
Client.
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Figure 1: DITA CMS Architecture
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Topics:

•
•
•
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•
•

Apply build-specific
configuration updates
Update the DITA CMS
version in the configuration
4.3.61 updates
4.3.57 updates
4.3.47 updates
4.3.33 updates
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Apply build-specific configuration updates
When a new DITA CMS build is released, it sometimes requires changes to the configuration.
The following table lists the configuration updates currently available:
Table 1: Configuration updates
Build Number
4.3.61

Configuration updates to apply
Update the Index Definition document on page 20
Edit the users.dtd file on page 21

4.3.57

Download and import configuration files on page 22

4.3.47

Download and import configuration files on page 24
Edit the resources.xml file on page 26
Edit the advancedSearchIndexes.xml file (DRM only) on page 27
Recommended updates on page 28

4.3.33

4.3.31

Correct the doctype declaration in the pivotlanguages.xml file
on page 29
Initial 4.3 release

1. Determine your current build number as follows:
a) In the DITA CMS Eclipse Client, click Help > About Eclipse SDK from the menu bar.
The About Eclipse SDK dialog is displayed.
b) Click the Installation Details button.
c) Click the Plug-ins tab.
d) Double-click the Provider column header to sort the names and look for IXIASOFT
Technologies Inc..
e) In the Plug-in Name column, look for DITA Content Management System.
f)

In the same row, look in the Version column, which lists the installed version
number.

2. Apply all the configuration changes for the builds that were released after your current
build version.

Updating the system configuration in the Content Store
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For example, if you were at version 1.1.0 and you wanted to update to version 1.1.5, then
you would need to apply the configuration changes from each version from 1.1.1 to 1.1.5.

Update the DITA CMS version in the configuration
After you have updated the Content Store to a new build, you should change the build number
in the textmlservercfg.properties file to reflect the current version number. This will also force
users to update their DITA CMS Eclipse Client to the installed build version.
To edit the textmlservercfg.properties file:
1. Expand the Content Store's Repository node and browse to /system/conf/ to locate the
textmlservercfg.properties file.
2. Right-click textmlservercfg.properties and click Check Out.
3. Double-click the file to open it in the XML editor area.
4. Set the value of ixia.cms.version to the build of the DITA CMS that you are installing.
For example:
ixia.cms.version=4.4.X

5. Save, close, and check in the file.
6. Inform users of the changes and request that they close and reopen their DITA CMS
to apply the changes.

4.3.61 updates
Perform the following procedures to update your Content Store to 4.3.61.
In this build, you have the following changes to make (all deployments):
• Update the Index Definition document on page 20
• Edit the users.dtd file on page 21
For deployments using DRM, you have the following additional changes to make:
• None.
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Update the Index Definition document
This procedure describes how to modify the Index Definition document to update your Content
Store to the current build.
Note: IXIASOFT recommends that you change the Index Definition document during off
hours only. This operation will require a reindexing of the modified indexes, which will
reduce the performance of the TEXTML Server.
When adding new indexes to the index definition, IXIASOFT recommends that you add them in
alphabetical order.
To update the Index Definition document:
1. Open the TEXTML Administration perspective by clicking the TEXTML Administration
shortcut on the tool bar. If the shortcut is not displayed, follow these steps:
a) Select Window > Open Perspective > Other
b) Click TEXTML Administration.
c) Click OK.
2. In the TEXTML Administration view, double-click the server. If your server is not
displayed in the view, you must add it to the view.
3. When the Connect as dialog opens, type your username and password and click OK.
4. Double-click the name of your docbase to open a connection to the Content Store.
5. Expand the Content Store's Repository node and right-click the Index Definition file and
select Lock.
6. Double-click the file to open it in the XML editor area.
7. Under <indexes>, locate the following <index> element:
<index NAME="type" SYNC="True">
<!-- Index referenced by the Advanced Search on attributes -->
<stringindex KEEPEXTRACTEDVALUES="False">
<elements>
<element DEPTH="INFINITE" XPATH="//@type"/>
</elements>
</stringindex>
</index>

8. In the index, delete SYNC="True". For example, it should look as follows:
<index NAME="type">
<!-- Index referenced by the Advanced Search on attributes -->
<stringindex KEEPEXTRACTEDVALUES="False">
<elements>
<element DEPTH="INFINITE" XPATH="//@type"/>
</elements>

Updating the system configuration in the Content Store
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</stringindex>
</index>

9. Locate the following <index> element:
<index NAME="wordCount" SYNC="True">
<numericindex KEEPEXTRACTEDVALUES="True">
<integerindexproperties/>
<elements>
<element DEPTH="0" XPATH="string-length(normalize-space(string(/))) string-length(replace(normalize-space(string(/)), ' ', ''))" />
</elements>
</numericindex>
</index>

10. In the index, delete SYNC="True". For example, it should look as follows:
<index NAME="wordCount">
<numericindex KEEPEXTRACTEDVALUES="True">
<integerindexproperties/>
<elements>
<element DEPTH="0" XPATH="string-length(normalize-space(string(/))) string-length(replace(normalize-space(string(/)), ' ', ''))" />
</elements>
</numericindex>
</index>

11. Save the Index Definition document.
12. Right-click the Index Definition document and select Check In.

Edit the users.dtd file
A couple of small changes are required in the users.dtd file to prevent text from being added in
the <role> and <group> elements.
To edit the users.dtd file:
1. Open the TEXTML Administration perspective by clicking the TEXTML Administration
shortcut on the tool bar. If the shortcut is not displayed, follow these steps:
a) Select Window > Open Perspective > Other
b) Click TEXTML Administration.
c) Click OK.
2. In the TEXTML Administration view, double-click the server. If your server is not
displayed in the view, you must add it to the view.
3. When the Connect as dialog opens, type your username and password and click OK.
4. Double-click the name of your docbase to open a connection to the Content Store.
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5. Expand the Content Store's Repository node and browse to /system/conf/ to locate the
users.dtd file.
6. Right-click the file and click Check Out.
7. Double-click the file to open it in the XML editor area.
8. Locate the element <!ELEMENT role (#PCDATA) and replace (#PCDATA) with EMPTY.
For example: <!ELEMENT role EMPTY
9. Locate the element <!ELEMENT group (#PCDATA) and replace (#PCDATA) with EMPTY.
For example: <!ELEMENT group EMPTY
10. Save, close, and check in the file.

4.3.57 updates
Perform the following procedures to update your Content Store to 4.3.57.
In this build, you have the following changes to make (all deployments):
• Download and import configuration files on page 22
For deployments using DRM, you have the following additional changes to make:
• None.

Download and import configuration files
The update package contains the files necessary to update the Preview view to allow it to generate
previews for topics containing either DITA 1.2 or DITA 1.3 elements.
1. Go to the following URL:
http://cms.ixiasoft.com/downloads/system_config/4.3/
2. Download the Build_4.3.57_updates.zip file to your computer.
3. Extract the .zip file to your local disk.
4. Open the TEXTML Administration perspective by clicking the TEXTML Administration
shortcut on the tool bar. If the shortcut is not displayed, follow these steps:
a) Select Window > Open Perspective > Other
b) Click TEXTML Administration.
c) Click OK.

Updating the system configuration in the Content Store
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5. In the TEXTML Administration view, double-click the server. If your server is not
displayed in the view, you must add it to the view.
6. When the Connect as dialog opens, type your username and password and click OK.
7. Double-click the name of your docbase to open a connection to the Content Store.
8. If you customized your Preview view, make a backup of your html folder and some files
in the resource folder.
a) Expand the Repository node and browse to /system/xsl/html.
b) Right-click the html folder and click Rename.
c) In the New Collection Name box, type a new name for the folder so it will not be
overwritten when you import the new files. For example, html_backup.
d) Click OK.
e) Browse to the /system/xsl/resource folder.
f)

Right-click the commonltr.css file and click Rename.

g) In the New Document Name box, type a new name for the file so it will not be
overwritten when you import the new files. For example, commonltr.backup.css.
h) Click OK.
i)

Repeat the previous steps to rename the commonrtl.css and messages.xml files.

9. Right-click Repository node and click Insert Documents.
10. Click Add Folder.
11. In the Browse For Folder dialog box, browse to the location where you extracted the
configuration files and select the system folder (for example,
C:\ixiasoft\Build_4.3.57_updates\config-base\system). Click OK.
In the Set As pane, the path should appear as /system/.
12. In the Set Options pane, select the Add and Replace checkboxes and clear Indexable.
For example:

13. Click OK.
The existing html folder is replaced.
14. If you had customized your Preview view, use your backup copy to re-implement your
changes to the Preview view. The Preview view is now based on the xhtml plugin of
the DITA OT 2.3.1.
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4.3.47 updates
Perform the following procedures to update your Content Store to 4.3.47.
In this build, you have the following changes to make (all deployments):
• Download and import configuration files on page 24
• Edit the resources.xml file on page 26
• Recommended updates on page 28
For deployments using DRM, you have the following additional changes to make:
• Edit the advancedSearchIndexes.xml file (DRM only) on page 27

Download and import configuration files
To update an existing installation to 4.3.47, you need to update configuration files to keep your
deployment up to date.
The following files must be updated:
• system/conf/conditionaltext.dtd
• system/conf/languages.dtd
• system/plugins/com.ixiasoft.dita13.dtd/IxiaDitabase.dtd (applies only to DITA 1.3 deployments)
• system/plugins/com.ixiasoft.dita13.dtd/IxiaMap-drm.dtd (applies only to DITA 1.3 deployments)
To facilitate this update, these files have been packaged in a .zip file and made available on the
IXIASOFT Downloads website.
To import the files:
1. Go to the following URL:
http://cms.ixiasoft.com/downloads/system_config/4.3/
2. Download the Build_4.3.47_updates.zip file to your computer.
3. Extract the .zip file to a local working directory.
For example:
C:\ixiasoft\

The following folders are available:
• config-base: Contains the files that must be updated in all deployments
• config-dita13: Contains the files that must be updated in DITA 1.3 deployments only

Updating the system configuration in the Content Store
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4. Open the TEXTML Administration perspective by clicking the TEXTML Administration
shortcut on the tool bar. If the shortcut is not displayed, follow these steps:
a) Select Window > Open Perspective > Other
b) Click TEXTML Administration.
c) Click OK.
5. In the TEXTML Administration view, double-click the server. If your server is not
displayed in the view, you must add it to the view.
6. When the Connect as dialog opens, type your username and password and click OK.
7. Double-click the name of your docbase to open a connection to the Content Store.
8. Right-click Repository and click Insert Documents.
9. Click Add Folder.
10. In the Browse For Folder dialog box, browse to the config-base/system folder in the
update directory (for example, C:\ixiasoft\Build_4.3.47_updates\config-base\system) and
click the system folder. Click OK.
In the Set As pane, the path should appear as /system/.
11. In the Set Options pane, select the Add and Replace checkboxes and clear Indexable.
For example:

12. Click OK.
13. (For DITA 1.3 deployments only!) In the Browse For Folder dialog box, browse to the
config-dita13/system folder in the update directory (for example,
C:\ixiasoft\Build_4.3.47_updates\config-dita13\system) and click the system folder. Click
OK.
In the Set As pane, the path should appear as /system/.
14. In the Set Options pane, select the Add and Replace checkboxes and clear Indexable.
For example:

15. Click OK.
The files are imported into the Content Store.
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Edit the resources.xml file
If you are updating to 4.3.47, you need to add a new type to the resources.xml file.
When a topic containing references to non-DITA files such as PDF files or videos was imported,
the non-DITA files were imported as resource objects of an undefined type, which resulted in
them not being searchable from the Search view. To import non-DITA files as searchable
resources, the resources.xml file must be edited to add a new type called "unknown".
Also, the ditaval-file type must be removed (if present), because ditaval files are not resources.
To edit the resources.xml file:
1. Open the TEXTML Administration perspective by clicking the TEXTML Administration
shortcut on the tool bar. If the shortcut is not displayed, follow these steps:
a) Select Window > Open Perspective > Other
b) Click TEXTML Administration.
c) Click OK.
2. In the TEXTML Administration view, double-click the server. If your server is not
displayed in the view, you must add it to the view.
3. When the Connect as dialog opens, type your username and password and click OK.
4. Double-click the name of your docbase to open a connection to the Content Store.
5. Expand the Content Store's Repository node and browse to /system/conf/ to locate the
resources.xml file.
6. Right-click the resources.xml file and click Check Out.
7. Double-click the file to open it in the XML editor area.
8. Add the following line to the file:
<type description="">unknown</type>

For example, the file should look as follows:
<resource>
<resourcetypes>
<type description="">pdf-graphics</type>
<type description="">pdf-legal</type>
<type description="">css</type>
<type description="">html</type>
<!-- Default type used by the import process -->
<type description="">unknown</type>
</resourcetypes>
</resource>

Updating the system configuration in the Content Store
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9. If the <type description="">ditaval-file</type> line is present, remove it from
the file.
10. Save, close, and check in the file.
11. Inform users of the changes.
The changes will be applied automatically once users close and then reopen their DITA CMS.
Users can also apply the changes without restarting their DITA CMS by clicking DITA CMS >
Synchronize Configuration.

Edit the advancedSearchIndexes.xml file (DRM only)
If you are updating to 4.3.47, you need to add a new search index to the advancedSearchIndexes
file.
This search index allows you to search with the filename in the Search view, in the Search in
drop-down list.
To add the index:
1. Open the TEXTML Administration perspective by clicking the TEXTML Administration
shortcut on the tool bar. If the shortcut is not displayed, follow these steps:
a) Select Window > Open Perspective > Other
b) Click TEXTML Administration.
c) Click OK.
2. In the TEXTML Administration view, double-click the server. If your server is not
displayed in the view, you must add it to the view.
3. When the Connect as dialog opens, type your username and password and click OK.
4. Double-click the name of your docbase to open a connection to the Content Store.
5. Expand the Content Store's Repository node and browse to /system/conf/ to locate the
advancedSearchIndexes file.
6. Right-click the advancedSearchIndexes file and click Check Out.
7. Double-click the file to open it in the XML editor area.
8. Add the following index to the file:
<index display="Filename" listable="false" name="Name" type="property"
views="ALL"/>
9. Save, close, and check in the file.
10. Inform users of the changes.
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The changes will be applied automatically once users close and then reopen their DITA CMS.
Users can also apply the changes without restarting their DITA CMS by clicking DITA CMS >
Synchronize Configuration.

Recommended updates
This section provides configuration updates that are recommended but not required.
In the access rights configuration, the methods of type outputtype (for example, Dita2Pdf,
Dita2htmlhelp, Dita2EclipseHelp, Dita2xhtml, etc.) should be updated to replace the <type
name="*"> element with the specific object types to which they can be applied. This ensures
that Build Manifests can be generated using the BuildManifest output type only (and not the
Dita2Pdf output type, for example).
To fix this issue:
1. Expand the Content Store's Repository node and browse to /system/conf folder.
2. Right-click the accessrights.xml file and select Check Out.
3. Open the accessrights.xml file in an XML editor.
4. Look for methods with the following type: type="outputtype".
For example:
<method name="Dita2Pdf" type="outputtype">
<notify enabled="false"/>
<conditionset operator="any">
<condition>
<current>
<type name="*">
<statuses>
<status>Authoring:*</status>
<status>Localization:*</status>
<status>Published:*</status>
</statuses>
</type>
...

5. Replace the <type name="*"> … </type> element with the following:
<type name="snapshot">
<statuses>
<status>Authoring:*</status>
<status>Localization:*</status>
</statuses>
</type>
<type name="map">
<statuses>
<status>Authoring:*</status>
<status>Localization:*</status>
<status>Published:*</status>
</statuses>
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</type>
<type name="topic">
<statuses>
<status>Authoring:*</status>
<status>Localization:*</status>
<status>Published:*</status>
</statuses>
</type>
<type name="image">
<statuses>
<status>Authoring:*</status>
<status>Localization:*</status>
<status>Published:*</status>
</statuses>
</type>

This ensures that the output type is applied to snapshots, maps, topics, and images only.
6. Repeat for all methods with the type="outputtype" type.
7. Save and check in the accessrights.xml file.
8. Inform users of the changes.
The changes will be applied automatically once users close and then reopen their DITA CMS.
Users can also apply the changes without restarting their DITA CMS by clicking DITA CMS >
Synchronize Configuration.

4.3.33 updates
Perform the following procedures to update your Content Store to 4.3.33.
In this build, you have the following changes to make (all deployments):
• Correct the doctype declaration in the pivotlanguages.xml file on page 29
For deployments using DRM, you have the following additional changes to make:
• No changes required.

Correct the doctype declaration in the pivotlanguages.xml file
A small change is required in the pivotlanguages.xml file to correct the doctype declaration.
To edit the pivotlanguages.xml configuration file:
1. Open the TEXTML Administration perspective by clicking the TEXTML Administration
shortcut on the tool bar. If the shortcut is not displayed, follow these steps:
a) Select Window > Open Perspective > Other
b) Click TEXTML Administration.
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c) Click OK.
2. In the TEXTML Administration view, double-click the server. If your server is not
displayed in the view, you must add it to the view.
3. When the Connect as dialog opens, type your username and password and click OK.
4. Double-click the name of your docbase to open a connection to the Content Store.
5. Expand the Content Store's Repository node and browse to /system/conf/ to locate the
pivotlanguages.xml file.
6. Right-click pivotlanguages.xml and click Check Out.
7. Double-click the file to open it in the XML editor area.
8. Locate the doctype declaration.
For example:
<!DOCTYPE comments PUBLIC "-//ixiasoft.com//cms//config//pivotLanguages"
"pivotLanguages.dtd">

9. Replace the word "comments" with "pivotlanguages".
For example:
<!DOCTYPE pivotlanguages PUBLIC "-//ixiasoft.com//cms//config//pivotLanguages"
"pivotLanguages.dtd">

10. Save, close, and check in the file.
11. Inform users of the changes.
The changes will be applied automatically once users close and then reopen their DITA CMS.
Users can also apply the changes without restarting their DITA CMS by clicking DITA CMS >
Synchronize Configuration.
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Updating the DITA CMS Eclipse Clients
The procedure for updating the DITA CMS depends on whether you are using dropins or an
update site to update the DITA CMS plugins.

Updating the DITA CMS plug-ins using an update site
This procedure describes how to update the DITA CMS plug-ins using an update site.
To update the plug-ins on the update site:
Note: This procedure assumes that you have two sets of update sites: test update sites
and production update sites.
1. Get the latest plug-ins from the IXIASOFT download site at the following URL:
http://cms.ixiasoft.com/downloads/plugins/
2. Click the release version; for example, 4.3.
3. Delete the content of the update site folders.
For example, delete the content of the following folders (keeping the same directory structure):
• C:\wwwroot\update-site\dita-cms
• C:\wwwroot\update-site\dita-doc
• C:\wwwroot\update-site\dita-cms-admin
• C:\wwwroot\update-site\textml-admin
4. Unzip the content of each update site zip file to the appropriate folder on the test update
sites.
For example:
Update site zip file

Directory

dita-cms-<version>.zip

C:\wwwroot\update-site\dita-cms

dita-doc-<version>.zip

C:\wwwroot\update-site\dita-doc

dita-cms-admin-<version>.zip C:\wwwroot\update-site\dita-cms-admin
textml-admin-<version>.zip
For example:

C:\wwwroot\update-site\textml-admin
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5. Test the plug-ins.
6. When satisfied that the plugins work as expected, repeat the procedure to install the
plug-ins on the production update site.

Updating the DITA CMS plug-ins when using dropins
This procedure describes how to update the DITA CMS plug-ins when using dropins.
To update the DITA CMS using dropins, you download the plug-ins from the IXIASOFT download
site and extract them to the Eclipse dropins folder. If you have many versions of the same plug-in
in the dropins directory, Eclipse loads the latest version.
It is up to you to determine how these plug-ins will be made available to the users. Some options
include:
• Automatically pushing the plug-ins to the user workstations or servers. The plug-ins will be
loaded the next time users restart their DITA CMS. If you need to make an important update,
you could ask users to restart their DITA CMS Eclipse Client right away. Note that you can
push the updates to the workstations even if the DITA CMS Eclipse Client is running.
• Putting the plug-ins in a central location and having users manually update them. For example,
you could create an update-cms.bat script that copies the plug-ins from the central location to
the workstations/servers and ask users to run the script as necessary. For example:
Note: The source of this file is available on the IXIASOFT download site at the following
URL:
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http://cms.ixiasoft.com/downloads/templates/4.3/updatecms43.bat.txt
Remove the .txt extension to make the file executable.
@echo off
REM The source of the dropins must be available on the network and be accessible by users
REM For example: \\acme-server\dita-cms-updates
REM Under this shared source, create a copy of each instance of your installation packages
REM For example:
REM \\acme-server\dita-cms-updates\cms44_x64
REM \\acme-server\dita-cms-updates\cms44_x64\eclipse.exe
REM \\acme-server\dita-cms-updates\cms44_x64\dropins
REM \\acme-server\dita-cms-updates\cms44_x64\plugins
REM \\acme-server\dita-cms-updates\cms44_x64\jre
REM \\acme-server\dita-cms-updates\cms44_admin_x64\
REM Update this installation package as necessary and then tell users to run this batch
file
REM Save this batch file in the root of each package directory, on the user machines and
on the central location
REM For example:
REM C:\eclipses\cms44_x64\update-cms.bat
REM \\acme-server\dita-cms-updates\cms44_x64\update-cms.bat
REM NOTE: if you use the following command to update the DITA CMS, Eclipse must NOT be
running
REM because this command will try to override files that are in use and cannot be replaced
REM Update the following line for each package directory
robocopy /mir \\acme-server\dita-cms-updates\cms44_x64 c:\eclipses\cms44_x64
REM
the
REM
REM
REM

To update the CMS while Eclipse is running, or if you simply added dropins or updated
eclipse.ini or start-cms.bat file
you can use the following command instead.
Update the following line for each package directory
robocopy /S /E \\acme-server\dita-cms-updates\cms44 c:\eclipses\cms44_x64

This utility replaces an existing installation with the updated installation packages. Save this
file in the root of each installation package as well as on the central location. For example:
C:\eclipses\cms44_x64\update-cms.bat
C:\eclipses\cms44_admin_x64\update-cms.bat
\\acme-server\dita-cms-updates\cms44_x64\update-cms.bat
\\acme-server\dita-cms-updates\cms44_admin_x64\update-cms.bat

Updating the Output Generator
This chapter describes how to update an existing 4.3 installation of the Output Generator.
Since the new 4.x structure ensures that all customer configurations are kept in separate files
and directories, you only need to extract the latest Output Generator package to update your
installation.
Note: This section describes how to update an existing 4.3 installation. To upgrade a 4.0
or 4.1 Output Generator to 4.3, see the DITA CMS 4.3 Upgrade Guide.
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Download and extract the Output Generator package
This procedure describes how to download and extract the Output Generator files.
1. Make a backup of the %OutputGenDir% directory.
2. Stop the Output Generator service.
Option

Description

On Windows Use one of the following methods:
Using the Services dialog box:
1. Double-click Services. The Services dialog opens.
2. Select the Output Generator service in the services list.
Note: The service name is the one you specified in the Output
Generator's configuration file, for example, Ixiasoft OutGen.
3. Click Stop the service.
Using the command line interface:
1. Click the Windows Start menu, right-click Command Prompt, and select
Run as administrator.
2. Enter the following command:
net stop outputgenerator

Wait until you see the confirmation message that it has stopped.
On Linux

1. Open a command-line interface to the Linux server.
2. Enter the following command:
/sbin/service outputgenerator stop

Wait until you see the confirmation message that it has stopped.

3. Go to the IXIASOFT Output Generator download page:
http://cms.ixiasoft.com/downloads/outputgenerator/
4. Click the DITA CMS version; for example, 4.3.
5. Click the link to the latest build available for the Output Generator (for example, 4.4.X).
The following files are listed:
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• outputgenerator-<version>_bin.zip
• outputgenerator-<version>_conf.zip
6. Download these files to the %OutputGenDir% directory.
7. Extract the files in the %OutputGenDir% directory.
When extracting files, you will get messages indicating that you are replacing existing files.
If you installed the Output Generator as described in this document, you can safely replace
existing files.
8. Delete the .zip files from the directory.
9. Run the integrator on the DITA-OT.
10. Start the Output Generator service.
Option

Description

On Windows Use one of the following methods:
Using the Services dialog box:
1. Double-click Services. The Services dialog opens.
2. Select the Output Generator service in the services list.
Note: The service name is the one you specified in the Output
Generator's configuration file, for example, Ixiasoft OutGen.
3. Click Start the service.
Using the command line interface:
1. Click the Windows Start menu, right-click Command Prompt, and select
Run as administrator.
2. Enter the following command:
net start outputgenerator

Wait until you see the confirmation message that it has stopped.
On Linux

1. Open a command-line interface to the Linux server.
2. Enter the following command:
/sbin/service outputgenerator start

Wait until you see the confirmation message that it has stopped.
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Related Links
Run the integrator on the DITA-OT on page 37

Run the integrator on the DITA-OT
The next step is to run the plugin integration process for the DITA-OT.
1. By default, the Output Generator uses version 1.8.5 of the DITA Open Toolkit. If you
are using a version of the DITA-OT other than 1.8.5:
a) Copy the following plugins from the %OutputGenDir%/data/DITA-OT1.8.5/plugins
directory to the %OutputGenDir%/data/%NewOT_Dir%/plugins directory (for example,
%OutputGenDir%/data/DITA-OT2.0/plugins):
• com.ixiasoft.dita.dtd: Includes the IXIASOFT DITA DTD specializations
• com.ixiasoft.images: Handles the .image file extension for the DITA CMS images
• com.ixiasoft.pdf.review: Handles the DITA CMS PDF-based review process (works
with versions 1.6.2 and up of the DITA Open Toolkit).
Note: You need to copy this plugin only if you want to change the ReviewPDF
and RedlinePDF transformation scenarios to a different version of the DITA-OT.
• org.mathml3: MathML 3 DTDs
• org.oasis-open.dita.mathml.doctypes: MathML DITA integration
2. The next step depends on the DITA-OT family:
DITA-OT 1.x family:

• On Windows: In the %OutputGenDir%/data/ directory, double-click
the _DITA-OT-1.8.5-integrator.bat file.
• On Linux:
1. In the %OutputGenDir%/data/%OT_Dir%/ directory, run
startcmd.sh.
2. At the command prompt, enter:
ant -f integrator.xml

The integration build runs and you should soon see BUILD
SUCCESSFUL.
DITA-OT 2.x family:

• On Windows: In the %OutputGenDir%/data/ directory, double-click
the _DITA-OT-2.3.1-integrator.bat file.
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• On Linux: In the %OutputGenDir%/data/%OT_Dir%/bin directory,
enter the following command:
./ant -f ../integrator.xml (Linux)

The integration build runs and you should soon see BUILD
SUCCESSFUL.

Related Links
Download and extract the Output Generator package on page 35

Make the required files executable (Linux only)
If you are running the Output Generator on Linux, you must run a script so that all required files
have the execution bit.
To make all required files executable:
Run the fix-execution-bit.sh file located in the bin directory of the Output Generator.
For example:
sh /opt/ixiasoft/OutputGenerators/prod_[version]/bin/fix-execution-bit.sh

Where [version] is replaced by the current release version number.

Update the Scheduler
This procedure describes how to update the Scheduler software to a more current build release.
To update the Scheduler software:
1. Create a backup of the Scheduler. For information about creating backups, see
Maintaining a DITA CMS Deployment Toolsmith's Guide.
2. Stop the Scheduler service.
Option

Description

On Windows

1. Click the Windows Start menu, right-click Command Prompt, and
select Run as administrator.
2. Navigate to the Scheduler bin file. For example:
cd C:\ixiasoft\Scheduler\bin
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Description
3. Enter the following command:
net stop Scheduler

Wait until you see the confirmation message that it has stopped.
On Linux

1. Open a command-line interface to the Linux server.
2. Enter the following command:
/sbin/service scheduler stop

Wait until you see the confirmation message that it has stopped.

3. Go to the IXIASOFT Scheduler download page:
http://cms.ixiasoft.com/downloads/scheduler/
4. Click the link to the latest version of the Scheduler and continue clicking the links until
you reach the following files:
• scheduler-<version>_bin.zip
• scheduler-<version>_conf.zip
Where <version> is the version of the Scheduler.
5. Download these files to the %SchedulerDir% directory.
6. Extract the files to the %SchedulerDir% directory.
7. When the files are extracted, delete the .zip files from the directory.
8. Restart the Scheduler service.
Option

Description

On Windows

1. Click the Windows Start menu, right-click Command Prompt, and
select Run as administrator.
2. Navigate to the Scheduler bin file. For example:
cd C:\ixiasoft\Scheduler\bin

3. Enter the following command:
net start Scheduler

On Linux

1. Open a command-line interface to the Linux server.
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Option

Description
2. Enter the following command:
/sbin/service scheduler start

Updating Web Author
Download and extract the Web Author package
The files required to install the Web Author are packaged in a zip file provided by IXIASOFT.
To download the Web Author package:
1. Go to the IXIASOFT Web Author download page:
http://cms.ixiasoft.com/downloads/webauthor/
2. Click the DITA CMS version; for example, 4.3.
3. Click the latest build available for the DITA CMS; for example, 4.4.X.
4. Select WebAuthor-<version>.zip, where <version> is the latest version of the Web
Author (for example, WebAuthor-4.4.X.zip).
5. Extract the zip file.
This package contains three directories, as follows:
• contentstore: Contains configuration that must be imported in the DITA CMS Content
Store.
• glassfish: Contains files used during the installation of the GlassFish Server and the CMS
Application Server.
• webauthor: Contains files used during the installation of the Tomcat Server and the Web
Author Application.
You will need these files when installing and configuring the Web Author.

Upgrade the online help
To get the latest documentation, you need to upgrade the online help.
1. Start the DITA CMS and open the TEXTML Administration perspective.
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2. Connect to your server and docbase.
3. Expand the docbase's repository node and navigate to the
system/cms.webauthor/help folder.
4. Right-click the help folder and select Insert Documents.
The Insert Documents Dialog window appears.
5. Click Add File and browse to the contentstore/cms.webauthor/help directory of
the extracted Web Author package provided by IXIASOFT.
6. Select the cms.webauthor.hlp file and click Open.
7. In the Set Options area, select Add and Replace.
8. Click OK.
The file is added to the DITA CMS configuration.

Upgrade the CMS Application Server
To update the CMS Application Server, you upload the glassfish/cmsappserver.ear file and deploy
it again.
1. Confirm that the CMS Application Server is connecting to the correct Content Store:
a) Open the %GlassFishDir%/domains/cmsappserver/config/CMSAppServer.config file
with a text editor.
b) Make sure that the <textml-connection> element points to the correct Content
Store. If that is not the case, update the attributes and save the file.
2. In a browser window, enter the following URL:
http://<glassfishserver>:4848

Where <glassfishserver> is the address of the machine where the GlassFish Server is installed.
The Oracle GlassFish Server Administration Console login page is displayed.
3. Enter the User Name and Password specified when you installed GlassFish (for example,
admin and admin).
4. Click Login.
The GlassFish Server Administration Console is displayed:
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5. In the Common Tasks panel, select Applications.
The Applications window is displayed.
6. Click the Redeploy action for the cmsappserver application.
The Redeploy Applications or Modules window is displayed.
7. Click Choose File, browse to the directory where you saved the
glassfish/cmsappserver.ear file provided in the Web Author package, and click Open.
The Deploy Applications or Modules window is displayed again.
8. Keep all options as is, as shown below, and click OK.
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The CMS Application Server is upgraded and enabled, as shown in the following diagram:

Upgrade the Web Author Application
To update the Web Author Application, you copy the webauthor/webauthor.war file and deploy
it again.
1. Stop the Tomcat service.
2. Delete the %TomcatDir%/webapps/webauthor directory.
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3. Delete the %TomcatDir%/webapps/webauthor.war file.
4. Copy the webauthor/webauthor.war file provided in the IXIASOFT Web Author package
to the following directory:
%TomcatDir%/webapps

Where %TomcatDir% is the location of the Tomcat installation. For example:
C:\Program Files\Apache Software Foundation\Tomcat 6.0\webapps (Windows)
/opt/tomcat6/webapps (Linux)

5. Restart the Tomcat service.

Update the Web Collaborative Reviewer
This procedure describes how to update the Web Collaborative Reviewer (WCR) to a more
current build release.
To update the WCR software:
1. Create a backup of the WCR. For information about creating backups, see Maintaining
a DITA CMS Deployment Toolsmith's Guide.
2. Download the WCR package:
a) Open the IXIASOFT Web Collaborative Reviewer download page:
http://cms.ixiasoft.com/downloads/wcr/
b) Click the link for the current version and continue clicking the links until you can
download the WCR .war file (wcr-[version].war).
Note: (Optional) If you want to rename the wcr application to something more
meaningful to SMEs who will be using the service, do so now before proceeding to
the next step, because the name of the WAR file determines the names of the files
that are installed. For clarity, the instructions that follow assume you have used the
original name, wcr.
3. Open a connection to the Tomcat server where the existing WCR application is installed.
4. Delete the old wcr folder from %TomcatDir%/webapps/.
5. Copy the wcr.war file into the %TomcatDir%/webapps/ directory.
Tomcat automatically expands the WAR file and installs the application in the wcr directory.
6. Wait a few seconds while the WCR is installed.
Note: You do not need to restart WCR or Tomcat after an update, because the existing
WCR configuration file in %TomcatDir%/conf is not overwritten during the update.

