Plug-in dependencies

Some plug-ins have dependencies on other plug-ins; if these required plug-ins are not present, installation will fail.

The following table lists the plug-in dependencies. Make sure that all required plug-ins are already installed or are provided in your bookmarks files.
Plug-in Requirements
DITA CMS Administration
  • TEXTML Server Administration

You can install the TEXTML Server Administration plug-in at the same time as you install the DITA CMS Administration plug-in

oXygen XML Extension (Editor)
  • oXygen XML Editor (third-party plug-in)

You can install the oXygen XML Editor plug-in at the same time as you install the oXygen XML Extension (Editor) plug-in. Your users will also need a valid Editor license.

oXygen XML Extension (Author)
  • oXygen XML Author (third-party plug-in)

You can install the oXygen XML Author plug-in at the same time as you install the oXygen XML Extension (Author) plug-in. Your users will also need a valid Author license.

XMetaL XMAX Extension

  • XMetaL XMAX (third-party Windows application)

XMetal XMAX is not installed as a plug-in; it's installed as a Windows application. You don't have to install it before you install the XMetaL XMAX Extension, but your users will not be able to edit content. Your users will also need a valid XMetaL XMAX license.

HyperSTE for XMetaL XMAX
  • XMetaL XMAX Extension

You can install the XMetaL XMAX Extension plug-in at the same time as you install the HyperSTE for XMetaL XMAX plug-in.