XMetaL XMAX requirements

The following lists summarizes the most important system requirements for XMetaL XMAX 8.0. See the XMetaL XMAX installation documentation for more information.

  • Microsoft Windows Vista, Windows 7, or Windows 8 (32-bit or 64-bit), or Server 2008
  • Eclipse SDK 4.3.2, 32-bit only
  • An internet connection with port 443 open (or a LAN connection for on-site XMLS configurations)
  • Microsoft Internet Explorer, version 6.00.2600.0000 to version 10 with EPM disabled
  • Active internet connection that permits an http/https connection to the jsls.xmetal.com site

Known issues during installation

If you get the following message during installation:
"Registration failed"

Make sure that your computer has a working internet connection and that a firewall is not blocking the TCP/IP port 443. This port (https) is used by XMAX to communicate with an XMetaL license server. Also, make sure that you have unused licenses available to allocate to users. If you have an XMetaL License server on-site, check with your IT administrator. Otherwise, contact XMetaL Support.