Using another version of the Open Toolkit

By default, the Output Generator uses version 2.3.1 of the DITA Open Toolkit, but you can use more than one version.

The Output Generator integrates the following DITA Open Toolkits:
  • 1.8.5 ("full easy install" version)
  • 2.3.1 ("zip package" version)
You can use any of these versions or even download and use another version. This can be useful if you need to support transformation scenarios that require different versions of the DITA-OT. For example, you might be using older transformation scenarios that require the 1.8.5 DITA-OT while your more recent transformation scenarios use the 2.3.1 DITA-OT. In this case, you would use two versions of the DITA-OT:
  • 2.3.1 for your recent transformation scenarios and for the DITA CMS scenarios
  • 1.8.5 for your older transformation scenarios

Specifying the DITA-OT version

You can configure a default DITA-OT version by setting the outgen.ot.version property in the outgen-init.properties file. See Configure the version of the DITA-OT used by default for more information.

You configure also configure a specific version of the DITA-OT to use per conductor file by setting the outgen.ot.version property at the top of the file, as shown below:
<?xml version="1.0" encoding="UTF-8"?>

<project name="conductor-ixia" default="" basedir=".">

	<!-- Set the version of the OT that will be used -->
	<property name="outgen.ot.version" value="1.8.5"/>

All the targets in the conductor file will use the version of the DITA-OT specified in the outgen.ot.version property. To generate the output using multiple versions of the DITA-OT, you create multiple conductor files.

For example, to support transformation scenarios that use the 1.8.5 and 2.3.1 DITA-OTs, you could create the following conductor files:
  • conductor-client-1.8.5.xml: Contains the 1.8.5 transformation scenarios
  • conductor-client-2.3.1.xml: Contains the 2.3.1 transformation scenarios

This section describes how to use another version of the Open Toolkit:

  • Step 1 (optional): Download the new version
  • Step 2: Configure the Output Generator to use this version