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About this document
This document describes the new features and bug fixes introduced in this build of DITA CMS Release 3.4.
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Updated DITA CMS documentation
The DITA CMS documentation set was updated to include the latest features and bug fixes.
PDF files
You can find the complete set in PDF format at the following location:
•

http://www.ixiasoft.com/default.asp?xml=/xmldocs/webpages/webpage-doc-cms34.xml

This document set includes the following updated documents:
•
•
•
•

Introduction to DITA CMS: Provides an overview of the DITA CMS concepts and functions.
DITA CMS User Guide (for oXygen): Describes the DITA CMS concepts and provides detailed procedures for
using the DITA CMS with the oXygen XML editor.
DITA CMS User Guide (for XMetaL): Describes the DITA CMS concepts and provides detailed procedures for
using the DITA CMS with the XMetaL XML editor.
DITA CMS System Administrator's Guide: Describes how to configure the DITA CMS application and customize
it for the specific workflow of documentation teams. Intended for CMS administrators.
Note: For a detailed description of the changes in each document, see the "New in this release" section at the
beginning of the document.

It also includes the following new documents:
•
•

Planning a DITA CMS Deployment: Provides the information required to plan a DITA CMS Version 3.4 deployment.
Intended for IT personnel and CMS administrators.
Installing the DITA CMS Eclipse Client: Describes how to package and deploy the DITA CMS Eclipse Client on
user workstations and in remote access solutions. Intended for CMS administrators.

Eclipse help
The DITA CMS User Guide is also available as Eclipse help in the DITA CMS Eclipse Client, build 051 and up. To
display the documentation:
1. In the DITA CMS client, select Help > Help Contents .
The Help - Eclipse SDK window is displayed.
2. If you are using XMetaL as your XML Editor, click DITA CMS User Guide for XMetaL. If you are using oXygen,
click DITA CMS User Guide for oXygen.
The DITA CMS User Guide is expanded and the table of contents is displayed.

Remove the DITA CMS Documentation [ixiasoft] plug-in
The Eclipse help for the DITA CMS User Guide is now packaged with the DITA CMS XMetaL and oXygen extension
plug-ins.
In previous releases, the documentation was packaged in the DITA CMS Documentation [ixiasoft] plug-in. You can
now remove this plug-in to ensure that you do not see two DITA CMS User Guides when opening the Eclipse help.
To remove the DITA CMS Documentation [ixiasoft] plug-in:
1. From the DITA CMS menu bar, select Help > About Eclipse SDK .
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The About Eclipse SDK window is displayed.
2. Click Installation Details.
The Eclipse SDK Installation Details window is displayed.
3. In the Installed Software pane, select DITA CMS Documentation [ixiasoft] and click Uninstall.
4. In the Uninstall Details window, click Finish.
5. Click Yes to restart Eclipse.
The DITA CMS Documentation [ixiasoft] plug-in is deleted.
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Isolate appended search results
When you append search results or when you locate documents using the Locate button, the search results are stored
in separate lists.
This is shown in the following diagram:

While the appended results are organized in separate lists, the Search Results functions available apply to all the results
in the window. For example, if you want to group the search results in the diagram above, the results from the previous
search and from the Locator search are combined before they are grouped.
You may want to work with the results of only one of the searches. This can be very useful, for example, when using
the Change Status function. If you try to change the status of a map, but some of its children do not have the appropriate
status, a dialog similar to the following is displayed:

To be able to easily change the status of the children before you change the status of the map, you may want to group
the results by status. To work with the Locator results only, you need to first isolate them.
To isolate search results:
1. In the Search Results window that contains the appended search results, select the title of the search and click Isolate
Results.
The Search Results window now only displays the results of the search selected.
Note: If you isolate the Locator results, all the results are displayed on a single page, so if you have many
search results (for example, 200 and more), loading the page may take a while.
If you isolate the Search results, they are displayed over multiple pages.

6

| Isolate appended search results | 7

2. Apply any of the Search Results window functions on the isolated results.
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Add a topic from the Search Results view to a reltable
You can now add a topic to a reltable by dragging it from the Search Results view.
To add a topic from the Search Results view to a reltable:
Note: The map must be locked.
1. Enter search criteria in the Search view.
Results are displayed in the Search Results view.
2. Drag and drop the topic from the Search Results view into one of the cells in the row.
The topic appears in the cell at the place you dropped it.

8

| Add a topic and its children to a reltable | 9

Add a topic and its children to a reltable
You can add a topic and all its children to a reltable in a single operation.
To add a topic and all its children:
Note: The map must be locked.
1. In the Table Display area of the Reltable Editing view, highlight the row where you want to add the topic and its
children.
The selected row's contents appear in the Row Display area.
2. Hold down the CTRL key and drag the topic from the DITA Map or Search Results view into one of the cells in
the row.
The topic and all its children appear in the cell at the place you dropped it.
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Configure the DITA CMS to resolve keyrefs when generating
output
When generating the output for a map, the DITA CMS can now resolve all keyrefs to determine the list of available
conditions.
When you select a map and select Generate Output from the right-click menu, the DITA CMS scans all the files in
the map to determine the list of conditions available.
In previous releases, when the map or one of its children contained a keyref, the DITA CMS did not resolve the keyref
to see if the referred object contained conditions. For example, consider the following scenario:
•

Map 1:
topicref href="keymap.ditamap"
topicref keyref="toto"
topicref href="topic1.xml" platform="Windows"

•

keymap.ditamap:
keydef key="toto" href="toto.xml"

•

toto.xml
<p platform="Unix"/>

In previous releases, only Windows would show up as an available condition, not Unix. You can now configure the
DITA CMS to resolve the keyrefs and include all available conditions.
To configure this option:
1.
2.
3.
4.
5.
6.

Open the TEXTML Administration perspective.
Connect to your server and docbase.
Expand the docbase node to display the Index Definition branch.
Right-click Index Definition and select Check out.
Open the Index Definition Document in an XML editor.
Under <indexes> add the following <index> elements:
<index NAME="keydef-pairs" SYNC="True">
<!-- System index required by the DITA CMS -->
<stringindex KEEPEXTRACTEDVALUES="True">
<elements>
<element DEPTH="0" XPATH="//keydef/concat(./@keys,'=',./@href)" />
</elements>
</stringindex>
</index>
<index NAME="mapref-childMaps" SYNC="True">
<stringindex KEEPEXTRACTEDVALUES="True">
<elements>
<element XPATH="//*[contains(@class, ' map/topicref ')][@format =
'ditamap']/@href" DEPTH="0"/>
</elements>
</stringindex>
</index>

7. Save, close, and check in the index definition document.
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Displaying topic titles in the DITA Map view
The DITA Map view lists the topics that are included in a map.
The topic title displayed in the map may come from different sources, such as the <title> element or <navtitle>
element or attribute, depending on how the topic is defined in the map:
•

If the topic is a reference to an existing topic file, the title displayed in the map is the value of the <title> element
set in the topic file. This will be the case for most topics.
For example, consider the following chapter in a map:
<bookmap id="lar1367336063736" xml:lang="eng">
<title>Sample Bookmap</title>
<chapter href="topicA.xml"/>
</bookmap>
The topicA.xml file has the following content:
<concept id="topicA" xml:lang="eng">
<title>Topic A title, taken from title element</title>
<conbody>
...
</conbody>
</concept>
The title of this chapter will be "Topic A title, taken from title element" in the DITA Map view, as shown below:

•

If the topic is not an href, that is, it does not reference an existing topic file, then the title is taken from the navtitle
attribute set directly on the topic, if available.
For example, consider the following map:
<bookmap id="lar1367336063736" xml:lang="eng">
<title>Sample Bookmap</title>
<chapter/>
<chapter href="lar1367336223394.xml" keys="lar1367336223394"/>
<chapter navtitle="Topic title, taken from navtitle attribute">
<topicref href="jan1237671609803.xml" keys="jan1237671609803"/>
<topicref href="jan1237595719998.xml" keys="jan1237595719998"/>
</chapter>
</bookmap>
The chapter highlighted in bold does not refer to an existing topic file; instead, it is used as a container chapter for
a set of topics. The title of this chapter will be "Topic title, taken from navtitle attribute", as shown below:
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•

If the topic is not an href and the navtitle attribute is not set directly on the topic, then the title is taken from
the <navtitle> element if set for that topic.
For example, consider the following map:
<bookmap id="lar1367336063736" xml:lang="eng">
<title>Sample Bookmap</title>
<chapter/>
<chapter href="lar1367336223394.xml" keys="lar1367336223394"/>
<chapter navtitle="Topic title, taken from navtitle attribute"/>
<chapter>
<topicmeta>
<navtitle>Topic title, taken from navtitle element</navtitle>
</topicmeta>
<topicref href="jan1237671609803.xml" keys="jan1237671609803"/>
<topicref href="jan1237595719998.xml" keys="jan1237595719998"/>
</chapter>
</bookmap>
The title of the chapter highlighted in bold will be "Topic title, taken from navtitle element", as shown below. Note
that, to show that the title was not set directly on the chapter element but rather was pulled from another element,
the title is displayed in italics and starts with a number sign (#):

Some notes:
•
•

For all maps other than bookmaps, the titles for topics that are not hrefs are only displayed when the Show Elements
option is selected.
The display of navtitle attributes and elements in the output depend on your transformation scenarios. This
section only covers how they are displayed in the DITA CMS.
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Import improvements
The Update Existing Documents feature when importing documents is now complete and available.
If a document already exists and the Update existing documents option is selected, the existing document is updated
with the contents of the imported document. If this option is not selected, a new document is created, with a new file
name. This is described in detail in the next procedures.

Import maps
The Import Maps wizard lets you add one or more maps authored outside the DITA CMS to the repository.
When you import a map, this map and its dependencies (for example, the map, topics, and images it refers to) are
imported into the repository and assigned the initial status (for example, Authoring:Draft). If one of the map dependencies
cannot be found (for example, one of its topic is missing), the import is cancelled and an error message is displayed.
When you import a map, its file name is added to the object's metadata in the originalFileName index and the
path relative to its containing map is added to the object's metadata in the OriginalRelativePath index.
Note: Any document you import is automatically assigned to you.
You can specify the following options when importing maps:
Option

Description

Update existing documents

When it imports a document, the DITA CMS determines if this document already exists
by checking:
1. That a document exists in the repository with the same name as the original file
name of the imported document.
2. If a document with the same name exists, and the Use relative path along with
file name to match documents to update option is selected, the DITA CMS also
checks that the base path of the imported document also matches the base path of
the document in the repository.
If a document already exists and the Update existing documents option is selected,
the existing document is updated with the contents of the imported document. If this
option is not selected, a new document is created, with a new file name.
Note that, to be updated, the document:
•
•

Default language

Must be in a lockable state (for example Authoring:Draft)
Must not be already locked by another user

All documents in the DITA CMS must have a designated language. If the documents
you are importing do not have a language attribute, the system will assign them the
language you select from this list. If the document you are importing has dependencies,
this language will also be assigned to these dependencies.
You can also set the Override unknown languages with default option. If you select
this option, when you import documents that reference a language that’s not configured
in your system, the system will replace these values with the default language specified.
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Option

Description

Images

If the maps you are importing reference images, you need to specify the type and format
of the images.
•

Type is an informative label that is written into the image metadata. Default values
are Line Art, Screen Capture, and Equation.
If an image is labeled Line Art or Screen Capture, the system will automatically
designate it as Needing Translation. Images labeled Equation are not designated
as needing translation; if these images are part of a map that's sent for localization,
the system will automatically promote them to [Localization_return_status] and
will not include them in the image localization kit.
You can set the translation designation for specific images as required once the
image has been imported, and the image type may be changed once the image is in
the repository.

•

Labels

Format may determine the output format of an image, depending on your system
setup.

You can assign one or more labels to a document and its dependencies. Labels are
added as metadata and improve searchability.

Import options
MAP IDs: Retain If this option is not selected, the map is assigned a new ID by the system. This will be
root map IDs
used as both the file name and as the map root ID. The imported map’s root ID is
overwritten.
If this option is selected, then the value of the imported map ID remains unchanged.
If no other map already has this file name, then this ID will also be used as the document
file name. If there is a conflict with an existing map file name, the system will assign
the imported map a unique file name, which will be different from the map ID.
Topicrefs: Remove
@navtitle and
@type from
<topicref>
containing @href

If this option is selected, then navtitle and type attributes are removed from
<topicref>s containing an href attribute when the map is imported.
When you are authoring DITA documents, there are several ways that you can specify
topic attributes such as type and title: at the map level and at topic level. DITA CMS
does not maintain map attributes automatically. If you keep these in the map, then
you’ll need to update them manually if, for example, you change the title of a topic.

Images: Images
If this option is selected and there are two (or more) images with the same file name,
have unique names then the system imports just one of them (randomly). If you leave this check box empty,
then all images are imported, they keep their duplicate titles, and the system assigns
unique file names.
Resources:
Resources have
unique names

If this option is selected and there are two (or more) resources with the same file name,
then the system imports just one of them (randomly). If you leave this check box empty,
then all resources are imported, keep their duplicate titles, and the system assigns file
names.

Import Base Path: Specifies the base path to use when replacing existing documents.
To import one or more maps and its dependencies:
1. Select File > Import...
The Import dialog appears.
2. Open the DITA CMS folder and select Import Maps.
3. Click Next.
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The Import Map(s) dialog appears.

4. Click Browse.
The Open dialog appears.
5. Navigate to the *.ditamap file(s), select them, and click Open.
The selected maps appear in the Maps to import list.
6. To replace existing documents with the contents of the imported documents, select Update existing documents. To
also use the relative path to match the documents to update, select Use relative path along with file name to match
documents to update.
7. Select the Default language.
8. If your maps reference images, select a Type and Format from the drop-down lists in the Images area.
9. Optional: To assign a label, click Select and add one or more labels. Click OK when done.
10. Optional: Click Next.
The Import Options dialog appears. Select any of the check boxes that apply:
•
•
•
•
•

MAP IDs: Retain root map IDs
Topicrefs: Remove @navtitle and @type attributes from <topicref> containing @href
Images: Images have unique names
Resources: Resources have unique names
Import Base Path

11. Click Finish.

Import topics
The Import Topics wizard lets you add one or more topics authored outside DITA CMS to the repository.
When you import a topic, this topic and its dependencies (for example, the topics and images it refers to) are imported
into the repository and assigned the initial status (for example, Authoring:Draft). If one of the topic dependencies cannot
be found (for example, one of its images is missing), the import is cancelled and an error message is displayed.
15
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When you import a topic, its file name is added to the object's metadata in the originalFileName index and the
path relative to its containing map is added to the object's metadata in the OriginalRelativePath index.
Note: Any document you import is automatically assigned to you.
You can specify the following options when importing topics:
Option

Description

Update existing documents

When it imports a document, the DITA CMS determines if this document already exists
by checking:
1. That a document exists in the repository with the same name as the original file
name of the imported document.
2. If a document with the same name exists, and the Use relative path along with
file name to match documents to update option is selected, the DITA CMS also
checks that the base path of the imported document also matches the base path of
the document in the repository.
If a document already exists and the Update existing documents option is selected,
the existing document is updated with the contents of the imported document. If this
option is not selected, a new document is created, with a new file name.
Note that, to be updated, the document:
•
•

Default language

Must be in a lockable state (for example Authoring:Draft)
Must not be already locked by another user

All documents in the DITA CMS must have a designated language. If the documents
you are importing do not have a language attribute, the system will assign them the
language you select from this list. If the document you are importing has dependencies,
this language will also be assigned to these dependencies.
You can also set the Override unknown languages with default option. If you select
this option, when you import documents that reference a language that’s not configured
in your system, the system will replace these values with the default language specified.

Images

If the topics you are importing reference images, you need to specify the type and
format of the images.
•

Type is an informative label that is written into the image metadata. Default values
are Line Art, Screen Capture, and Equation.
If an image is labeled Line Art or Screen Capture, the system will automatically
designate it as Needing Translation. Images labeled Equation are not designated
as needing translation; if these images are part of a map that's sent for localization,
the system will automatically promote them to [Localization_return_status] and
will not include them in the image localization kit.
You can set the translation designation for specific images as required once the
image has been imported, and the image type may be changed once the image is in
the repository.

•

Labels

Format may determine the output format of an image, depending on your system
setup.

You can assign one or more labels to a document and its dependencies. Labels are
added as metadata and improve searchability.

Import options
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Option

Description
Images: Images
If this option is selected and there are two (or more) images with the same file name,
have unique names then the system imports just one of them (randomly). If you leave this check box empty,
then all images are imported, they keep their duplicate titles, and the system assigns
unique file names.
Resources:
Resources have
unique names

If this option is selected and there are two (or more) resources with the same file name,
then the system imports just one of them (randomly). If you leave this check box empty,
then all resources are imported, keep their duplicate titles, and the system assigns file
names.

Import Base Path: Specifies the base path to use when replacing existing documents.
To import one or more topics and its dependencies:
1. Select File > Import...
The Import dialog appears.
2. Open the DITA CMS folder and select Import Topics.
3. Click Next.
The Import Topic(s) dialog appears.

4. Click Browse.
The Open dialog appears.
5. Navigate to the topics, select them, and click Open.
The selected topics appear in the Topics to import list.
6. To replace existing documents with the contents of the imported documents, select Update existing documents. To
also use the relative path to match the documents to update, select Use relative path along with file name to match
documents to update.
7. Select the Default language.
8. If your topics reference images, select a Type and Format from the drop-down lists in the Image area.
9. Optional: To assign a label, click Select and add one or more labels. Click OK when done.
10. Optional: Click Next.
17
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The Import Options dialog appears. Select any of the check boxes that apply:
•
•
•

Images: Images have unique names
Resources: Resources have unique names
Import Base Path

11. Click Finish.

Import images
The Import Images wizard offers you a way to import images in bulk.
When you import an image, its file name is added to the object's metadata in the originalFileName index and the
path relative to its containing map is added to the object's metadata in the OriginalRelativePath index.
Note: Any document you import is automatically assigned to you.
You can specify the following options when importing images:
Option

Description

Update existing documents

When it imports a document, the DITA CMS determines if this document already exists
by checking:
1. That a document exists in the repository with the same name as the original file
name of the imported document.
2. If a document with the same name exists, and the Use relative path along with
file name to match documents to update option is selected, the DITA CMS also
checks that the base path of the imported document also matches the base path of
the document in the repository.
If a document already exists and the Update existing documents option is selected,
the existing document is updated with the contents of the imported document. If this
option is not selected, a new document is created, with a new file name.
Note that, to be updated, the document:
•
•

Default language

Must be in a lockable state (for example Authoring:Draft)
Must not be already locked by another user

All documents in the DITA CMS must have a designated language. If the documents
you are importing do not have a language attribute, the system will assign them the
language you select from this list. If the document you are importing has dependencies,
this language will also be assigned to these dependencies.
You can also set the Override unknown languages with default option. If you select
this option, when you import documents that reference a language that’s not configured
in your system, the system will replace these values with the default language specified.

Images

You need to specify the type and format of the images you are importing.
•

Type is an informative label that is written into the image metadata. Default values
are Line Art, Screen Capture, and Equation.
If an image is labeled Line Art or Screen Capture, the system will automatically
designate it as Needing Translation. Images labeled Equation are not designated
as needing translation; if these images are part of a map that's sent for localization,
the system will automatically promote them to [Localization_return_status] and
will not include them in the image localization kit.
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Option

Description
You can set the translation designation for specific images as required once the
image has been imported, and the image type may be changed once the image is in
the repository.
•

Labels

Format may determine the output format of an image, depending on your system
setup.

You can assign one or more labels to a document and its dependencies. Labels are
added as metadata and improve searchability.

Import options
Images: Images
If this option is selected and there are two (or more) images with the same file name,
have unique names then the system imports just one of them (randomly). If you leave this check box empty,
then all images are imported, they keep their duplicate titles, and the system assigns
unique file names.
Import Base Path: Specifies the base path to use when replacing existing documents.
1. Select File > Import...
The Import dialog appears.
2. Open the DITA CMS folder and select Import Images.
3. Click Next.
The Import Image(s) dialog appears.

4. Click Browse.
The Open dialog appears.
5. Navigate to the images, select them, and click Open.
The selected images appear in the Images to import list.
6. To replace existing documents with the contents of the imported documents, select Update existing documents. To
also use the relative path to match the documents to update, select Use relative path along with file name to match
documents to update.
19
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7. Select the Default language.
8. Select a Type and Format of the images you are importing.
You can change the values for individual images later on, if you want.
9. Optional: To assign a label, click Select and add one or more labels. Click OK when done.
10. Optional: Click Next.
The Import Options dialog appears. Select any of the check boxes that apply:
•
•

Images: Images have unique names
Import Base Path

You can also enter a description for the image.
11. Click Finish.

Import multiple resolution images
The Import Images With Multiple Format wizard lets you import images and their different resolutions in bulk into the
repository.
When you publish in different media, you most likely use different image resolutions for each output. You might, for
example, want to use a low resolution interlaced JPEG with output that’s designed for the web and have a high-resolution
version for PDFs.
This procedure lets you simultaneously import all the different formats that you use for each image and automatically
assign them to the different output formats. You can, at the same time, specify the default format and whether the images
will need to be translated.
Note: Any document you import is automatically assigned to you.
Pre-requisites
•

Each image resolution must be saved in a different directory. It is recommended to create an import directory with
a subdirectory for each type of resolution; for example:
C:\images_import\Medres
C:\images_import\PDF
C:\images_import\Web
C:\images_import\Hires
...

•

When multi-resolution images are imported into the system, they are assigned a collective ID and stored in a zip file
with the extension .image. To successfully assign the different resolutions to the correct DITA CMS image object,
all the different resolutions of an image must share the same file name. For example, you might have a file called
bike.jpg that you'd use for web output, and another called bike.png that you'd use for glossy brochures.

You can specify the following options when importing images:
Option

Description

Default language

All documents in the DITA CMS must have a designated language. If the documents
you are importing do not have a language attribute, the system will assign them the
language you select from this list. If the document you are importing has dependencies,
this language will also be assigned to these dependencies.
You can also set the Override unknown languages with default option. If you select
this option, when you import documents that reference a language that’s not configured
in your system, the system will replace these values with the default language specified.
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Option

Description

Type and Default format

You need to specify the type and default format of the images you are importing.
•

Type is an informative label that is written into the image metadata. Default values
are Line Art, Screen Capture, and Equation.
If an image is labeled Line Art or Screen Capture, the system will automatically
designate it as Needing Translation. Images labeled Equation are not designated
as needing translation; if these images are part of a map that's sent for localization,
the system will automatically promote them to [Localization_return_status] and
will not include them in the image localization kit.
You can set the translation designation for specific images as required once the
image has been imported, and the image type may be changed once the image is in
the repository.

•

Format may determine the output format of an image, depending on your system
setup.

To import multiple resolution images:
1. Select File > Import...
The Import dialog appears.
2. Open the DITA CMS folder and select Import Images With Multiple Formats.
3. Click Next.
The Images With Multiple Formats dialog appears.

4. Select the image Format to import and click Browse.
The Browse For Folder dialog appears.
5. Navigate to the directory that contains the images for this format and click OK.
The selected directory appears in the Folder Path list.
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6. Repeat steps 4-5 as required for all the formats that you are using.
7. Optional: Click Next.
The Specify Default Values dialog appears.

The values you specify will be used for all the resolutions of all the images. You can change the values for individual
images later on, if you want.
8. Enter a Description.
9. Select the Default language.
10. Select a Type.
11. Select the Default format.
This may determine the output format that an image will be used for, depending on your system setup.
12. Select or deselect Needs Translation, as required.
Certain types of graphics may automatically enable this check box. This lets you override the default.
You can change the values for individual images later on, if you want.
13. Click Finish.
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